JBoss vs Java JDK Version Matrix

Which version of the JDK is required for which versions of JBoss AS?

JBoss version series 3.2.x 4.0.x 5.0.x (HEAD)
compiles with JDK version 1.3/1.4 1.4/5.0 1.4/5.0
runs under JDK version 1.3/1.4/5.0 1.4/5.0 1.4/5.0

Notes:

  • JBoss AS 3.2.6+ and 4.0.1+ are the ONLY versions to be fully functional under JDK 5, due to JMX issues. See RunJBossWithJ2SDK1.5Beta for more details.
  • JBoss AS 3.2.6 doesn’t run with JDK 1.3. This issue is fixed in the JBoss AS 3.2.7.
  • JBoss AS 4.0.0 runs under JDK 1.5, but the jconsole utility will not work with it. You need 4.0.1+, 3.2.7+ to use jconsole.
  • ….
Advertisements